µLua DS - Forum officiel | Official forum Index du Forum

µLua DS - Forum officiel | Official forum
Le bon endroit pour en savoir plus sur MicroLua et pour parler de vos projets ! | The right place to learn more about MicroLua and talk about your projects !

 FAQFAQ   RechercherRechercher   MembresMembres   GroupesGroupes   S’enregistrerS’enregistrer   ProfilProfil   Se connecter pour vérifier ses messages privésSe connecter pour vérifier ses messages privés   ConnexionConnexion 

Problème avec le son
Aller à la page: 1, 2  >
 
Poster un nouveau sujet   Répondre au sujet    µLua DS - Forum officiel | Official forum Index du Forum -> Section française -> Demande d'aide
Sujet précédent :: Sujet suivant  
Auteur Message
Sharkou


Hors ligne

Inscrit le: 22 Fév 2012
Messages: 84
Localisation: Bretagne

MessagePosté le: Ven 24 Fév 2012 - 16:19    Sujet du message: Problème avec le son Répondre en citant

Bonjour,

J'essaye de faire fonctionner les sons mais la musique ne fonctionne quand je lance le programme :

 
Code:


Sound.loadBank("soundbank.bin")
Sound.loadMod(0)

while not Keys.newPress.Start do
    Controls.read()
    
    Sound.startMod(0, PLAY_ONCE)
    
render()
end

Sound.unloadMod(0)
Sound.unloadBank()



J'ai un dossier "Mods" dans lequel il y a un son wav et j'ai aussi mis le fichier "soundbank.bin" à côté de code.lua mais ça ne marche pas :/


Revenir en haut
Publicité






MessagePosté le: Ven 24 Fév 2012 - 16:19    Sujet du message: Publicité

PublicitéSupprimer les publicités ?
Revenir en haut
thermo_nono
Modérateur

Hors ligne

Inscrit le: 31 Déc 2008
Messages: 2 415
Localisation: La Géhenne

MessagePosté le: Ven 24 Fév 2012 - 16:33    Sujet du message: Problème avec le son Répondre en citant

avec un son wave, il ne faut pas utiliser loadMod(), mais loadSFX()

 
Code:
Sound.loadBank("soundbank.bin")
Sound.loadSFX(0)
while not Keys.held.Start do
 Controls.read()
  Sound.startSFX(0)
 render()
end
Sound.unloadSFX(0)
Sound.unloadBank()









_________________
“Qui reçoit une idée de moi reçoit de la connaissance sans diminuer la mienne, comme celui qui allume sa chandelle à la mienne reçoit la lumière sans me plonger dans l’obscurité.” - Thomas Jefferson


Revenir en haut
Visiter le site web du posteur MSN
Papymouge
Modérateur

Hors ligne

Inscrit le: 10 Mai 2009
Messages: 693
Localisation: Vittel (88)

MessagePosté le: Ven 24 Fév 2012 - 16:38    Sujet du message: Problème avec le son Répondre en citant

Et évite aussi de mettre le Sound.start... en continu dans une boucle, il va démarrer à chaque passage. Démarre le plutôt avec un bouton.


 
Code:
 While true do
   Controls.read()
   if Keys.newPress.A then Sound.start... end
 render()
 end


_________________
La page de mes projets
L'ancienne page de mes projets


Revenir en haut
thermo_nono
Modérateur

Hors ligne

Inscrit le: 31 Déc 2008
Messages: 2 415
Localisation: La Géhenne

MessagePosté le: Ven 24 Fév 2012 - 16:39    Sujet du message: Problème avec le son Répondre en citant

ha oui... ça j'avais pas remarqué dans mon élan.
_________________
“Qui reçoit une idée de moi reçoit de la connaissance sans diminuer la mienne, comme celui qui allume sa chandelle à la mienne reçoit la lumière sans me plonger dans l’obscurité.” - Thomas Jefferson


Revenir en haut
Visiter le site web du posteur MSN
Sharkou


Hors ligne

Inscrit le: 22 Fév 2012
Messages: 84
Localisation: Bretagne

MessagePosté le: Ven 24 Fév 2012 - 17:04    Sujet du message: Problème avec le son Répondre en citant

Bizarre je n'entends toujours aucun son Confused

EDIT : Je pense savoir d'où vient le problème.


Revenir en haut
thermo_nono
Modérateur

Hors ligne

Inscrit le: 31 Déc 2008
Messages: 2 415
Localisation: La Géhenne

MessagePosté le: Ven 24 Fév 2012 - 17:45    Sujet du message: Problème avec le son Répondre en citant

sinon, ouvre le "Soundbank.h" avec un éditeur de texte pour vérifier le numéro du son. 


edit : et vérifie le bouton de volume sur ta DS  Razz
_________________
“Qui reçoit une idée de moi reçoit de la connaissance sans diminuer la mienne, comme celui qui allume sa chandelle à la mienne reçoit la lumière sans me plonger dans l’obscurité.” - Thomas Jefferson


Revenir en haut
Visiter le site web du posteur MSN
spectrenoir06


Hors ligne

Inscrit le: 13 Jan 2012
Messages: 184
Localisation: Paris

MessagePosté le: Ven 24 Fév 2012 - 18:10    Sujet du message: Problème avec le son Répondre en citant

Si t'est sur MLS c'est normal
sinon a tu bien mis les son et musique dans soundbank.bin ?


Revenir en haut
Visiter le site web du posteur
Sharkou


Hors ligne

Inscrit le: 22 Fév 2012
Messages: 84
Localisation: Bretagne

MessagePosté le: Ven 24 Fév 2012 - 18:20    Sujet du message: Problème avec le son Répondre en citant

spectrenoir06 a écrit:

sinon a tu bien mis les son et musique dans soundbank.bin ?



soundbank.h tu veux dire ?
Merci ça fonctione bien sur ma DS Smile
(j’essayais au début sur l'émulateur ^^)

EDIT : Par contre quand je veux mettre un son de moi (et pas les sons de l'exemple), je supprimes tout dans soundbank.h et je mets :

 
Code:

 #define SFX_MonSon    0




à la place mais quand j'appuie sur A j'entends le son de l'ambulance (celui de l'exemple) et non le miens Confused
Comment faire ?


Revenir en haut
Reylak
Administrateur

Hors ligne

Inscrit le: 24 Nov 2008
Messages: 2 838
Localisation: Toulouse

MessagePosté le: Ven 24 Fév 2012 - 19:54    Sujet du message: Problème avec le son Répondre en citant

Bourrinage xD

Faut utiliser le logiciel qui est fourni dans le pack... Que l'on ne fournit plus par défaut. =_=
Ici : http://code.google.com/p/microlua/downloads/detail?name=Utilities.zip&c…
Tu télécharges le .zip, t'as un dossier Soundbank maker, je pense que tu sauras t'en servir :p Là tu auras le fichier soundbank.bin qui contient tes sons.
_________________


Plein d'infos sur le SourceForge !


Revenir en haut
Visiter le site web du posteur MSN Skype
thermo_nono
Modérateur

Hors ligne

Inscrit le: 31 Déc 2008
Messages: 2 415
Localisation: La Géhenne

MessagePosté le: Ven 24 Fév 2012 - 20:24    Sujet du message: Problème avec le son Répondre en citant

... et un Soundbank.h qui contiendra la description du contenu du Sounbank.bin (les numéros correspondant aux sons). 
_________________
“Qui reçoit une idée de moi reçoit de la connaissance sans diminuer la mienne, comme celui qui allume sa chandelle à la mienne reçoit la lumière sans me plonger dans l’obscurité.” - Thomas Jefferson


Revenir en haut
Visiter le site web du posteur MSN
Sharkou


Hors ligne

Inscrit le: 22 Fév 2012
Messages: 84
Localisation: Bretagne

MessagePosté le: Ven 24 Fév 2012 - 20:37    Sujet du message: Problème avec le son Répondre en citant

Merci beaucoup, je pense que ça devrait marcher Smile
EDIT : Quand je lance le fichier.lua sur ma DS, ça ne démarre pas et ça reste bloqué mais je pense que ça vient de la taille de la musique.wav (elle fait 19,7 Mo).


Revenir en haut
thermo_nono
Modérateur

Hors ligne

Inscrit le: 31 Déc 2008
Messages: 2 415
Localisation: La Géhenne

MessagePosté le: Ven 24 Fév 2012 - 22:25    Sujet du message: Problème avec le son Répondre en citant

ha oui ! pour les musiques il vaut mieux utiliser des .MOD 
les waves c'est surtout pour les sons. (très courts)
_________________
“Qui reçoit une idée de moi reçoit de la connaissance sans diminuer la mienne, comme celui qui allume sa chandelle à la mienne reçoit la lumière sans me plonger dans l’obscurité.” - Thomas Jefferson


Revenir en haut
Visiter le site web du posteur MSN
Sharkou


Hors ligne

Inscrit le: 22 Fév 2012
Messages: 84
Localisation: Bretagne

MessagePosté le: Ven 24 Fév 2012 - 22:29    Sujet du message: Problème avec le son Répondre en citant

Ok ^^
Par contre j'ai pas trouvé de logiciel pour convertir des sons .mp3 en .mod (ni en .xm, .s3m et .it d'ailleurs), apparemment c'est impossible ?!


Revenir en haut
thermo_nono
Modérateur

Hors ligne

Inscrit le: 31 Déc 2008
Messages: 2 415
Localisation: La Géhenne

MessagePosté le: Ven 24 Fév 2012 - 22:38    Sujet du message: Problème avec le son Répondre en citant

oui, c'est impossible (à ma connaissance) car les fichiers "MOD" fonctionnent comme des fichiers midi (c'est une sorte de partition). Il existe des logiciels qui convertissent du midi (.MID) en MOD ou IT. De toutes façons, numériser du wave pour le récupérer dans un MOD (en tant que sample) allourdirait considérablement le .MOD et serait donc inutilisable sur la petite mémoire de la DS. 
_________________
“Qui reçoit une idée de moi reçoit de la connaissance sans diminuer la mienne, comme celui qui allume sa chandelle à la mienne reçoit la lumière sans me plonger dans l’obscurité.” - Thomas Jefferson


Revenir en haut
Visiter le site web du posteur MSN
Sharkou


Hors ligne

Inscrit le: 22 Fév 2012
Messages: 84
Localisation: Bretagne

MessagePosté le: Ven 24 Fév 2012 - 22:44    Sujet du message: Problème avec le son Répondre en citant

Comment faire alors ? Confused

P.S : GG 2 000 message Mr. Green


Revenir en haut
Contenu Sponsorisé






MessagePosté le: Aujourd’hui à 03:16    Sujet du message: Problème avec le son

Revenir en haut
Montrer les messages depuis:   
Poster un nouveau sujet   Répondre au sujet    µLua DS - Forum officiel | Official forum Index du Forum -> Section française -> Demande d'aide Toutes les heures sont au format GMT + 1 Heure
Aller à la page: 1, 2  >
Page 1 sur 2

 
Sauter vers:  

Index | Creer un forum | Forum gratuit d’entraide | Annuaire des forums gratuits | Signaler une violation | Conditions générales d'utilisation
Powered by phpBB © 2001, 2005 phpBB Group
Traduction par : phpBB-fr.com